L2 транспорт через TP-LINK TL-WR842ND

Комментарии ()

Прошивку OpenWRT для роутер TL-WR842ND беремо тут. На момент написання статті, для ревізії V2 це файл openwrt-15.05.1-ar71xx-generic-tl-wr842n-v2-squashfs-factory.bin

Причому прийшлось його переіменувати в TL-WR842ND_V2_140922_RU.bin, оскільки рідна прошивка відмовлялась приймати на борт оригінальну назву файлу

Редагую конфігурацію мережі

vi /etc/config/network

В моєму випадку, прописую локальну ip

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdaf:c070:c667::/48'

config interface 'lan'
        option ifname 'eth1 tap0'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '10.254.254.4'
        option netmask '255.255.255.29'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

Також прописую dns

vi /etc/resolv.conf

Дозволяєсо ssh через wan інтерфейс, добавляємо правило в /etc/config/firewall

#Allow SSH
config 'rule'
option 'src' 'wan'
option 'target' 'ACCEPT'
option 'proto' 'tcp'
option 'dest_port' '22'

Пробуємо поставити vtund

opkg update
opkg install vtund 
Unknown package 'vtund'.
Collected errors:
 * opkg_install_cmd: Cannot install package vtund.

Пакет беремо тут та копіюємо на желізку (я використовую Winscp)

інсталюємор vtun

opkg install vtun_3.0.2-1_ar71xx.ipk

Редагуємо конфіг vtun для клієнта

options {
  port 5005;            # Connect to this port.
  timeout 60;           # General timeout

  # Path to various programs
  ppp           /usr/sbin/pppd;
  ifconfig      /sbin/ifconfig;
  route         /sbin/route;
  firewall      /sbin/ipchains;
  ip            /sbin/ip;
}


# Ethernet example. Session 'lion'.
 connectio_name{
  passwd  mypassword;    # Password
  type  ether;          # Ethernet tunnel
  device tap0;
  persist yes;
  up {
        ifconfig "%% 20.20.20.2 netmask 255.255.255.0";
  };
  down {
        ifconfig "%% down";
  };
}

Створюємо скрипт запуску vtun-клієнта /etc/init.d/vtunclient

#!/bin/sh /etc/rc.common
# Example script
# Copyright (C) 2007 OpenWrt.org
 
START=10
STOP=15
 
start() {        
        echo start
        vtund connection_name server.host

	
	
}                 
 
stop() {          
        echo stop
        # commands to kill application 
}

Активізуємо скрипт запуску

chmod +x /etc/init.d/vtunclient
/etc/init.d/vtunclient enable

Проблеми

При включені другого тунеля, tap інтерфейс постійно Up/Down - то піднімався, то падав. Допоміг запуск vtund  не в режимі демона (vtund -n). Як виявилось, клієнт не хотів працювати по udp протоклу, видалив proto udp на сервері, усе пішло

Конфігураційний файл сервера

options {
  port 5005; 
  syslog        daemon;
  ifconfig      /sbin/ifconfig;

}

# Default session options
default {
  compress no;          # Compression is off by default
  speed 0;              # By default maximum speed, NO shaping
}

connection_name {
  passwd  a;
  type  ether;          # Ethernet tunnel
  device tap1;          # Device tap0
  compress no;
  encrypt no;
  #compress  lzo:1;     # LZO compression level 1
  #encrypt  yes;                # Encryption
  stat  no;             # Log connection statistic
  keepalive yes;        # Keep connection alive

  up {
        ifconfig "%% up";
        ifconfig "%% bridge4 addm tap1";
  };

  down {

  };
}

 


Читать далее

Paessler SNMP Tester

Комментарии ()

Накінець то хоть хтось зробив простий інтерфейс для роботи/відладки по SNMP


Читать далее

Postgres

Комментарии ()
  • sudo -u postgres psql - зайти в консоль postgres'а
  • \l - показати список баз даних
  • \с {name} - вибрати базу даних
  • \dt - показати перелік таблиць вибраної бази даних
  • \d+ <tablename> - показати схему таблиці
  • \q - вихід з консолі

Зміна пароля користувача

alter user <username> with password '<password>';

Restore

psql dbname < infile

Dump

pg_dump -h host1 dbname > dbname.sql

 


Читать далее

Perl warning setting locale failed в Ubuntu 14.04

Комментарии ()
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_TIME = "uk_UA.UTF-8",
	LC_MONETARY = "uk_UA.UTF-8",
	LC_ADDRESS = "uk_UA.UTF-8",
	LC_TELEPHONE = "uk_UA.UTF-8",
	LC_NAME = "uk_UA.UTF-8",
	LC_MEASUREMENT = "uk_UA.UTF-8",
	LC_IDENTIFICATION = "uk_UA.UTF-8",
	LC_NUMERIC = "uk_UA.UTF-8",
	LC_PAPER = "uk_UA.UTF-8",
	LANG = "C"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_ALL to default locale: No such file or directory

Вирішення:

sudo locale-gen uk_UA.UTF-8
sudo dpkg-reconfigure locales

 


Читать далее

Налаштування Edge-core на доступ

Комментарии ()
Console(config)#username admin password 0 mypassword
Console(config)#username admin access-level 15

Console(config)#vlan database
Console(config-vlan)#vlan 200 media ethernet state active
Console(config-vlan)#vlan 141 media ethernet state active
Console(config-vlan)#ex
Console(config)#

Console(config)#ip dhcp snooping
Console(config)#ip dhcp snooping information option
Console(config)#ip dhcp snooping information policy replace
Console(config)#ip dhcp snooping vlan 141
Console(config)#

Console(config)#interface ethernet 1/10
Console(config-if)#switchport mode trunk
Console(config-if)#switchport allowed vlan add 141,200 tagged
Console(config-if)#ip dhcp snooping trust
Console(config-if)#ex
Console(config)#

Console(config)#interface ethernet 1/1-8
Console(config-if)#switchport mode access
Console(config-if)#switchport allowed vlan add 141 untagged
Console(config-if)#switchport native vlan 141
Console(config-if)#ip source-guard sip-mac
Console(config-if)#ex

Console(config)#interface vlan 200
Console(config-if)#ip address 10.15.200.16 255.255.255.0
Console(config-if)#ex
Console(config)#ip default-gateway 10.15.200.254
Console(config)#

Console(configf)#snmp-server group gsavio v3 priv read defaultview
Console(configf)#snmp-server user savio gsavio v3 auth sha password priv des56 password

Задати 100Мбіт для SFP

media-type sfp-forced 100fx

Traffic Segmantation (ізоляція портів в одному vlan'і)

pvlan
pvlan session 1 uplink ethernet 1/25 downlink ethernet 1/1-24,26-28

після pvlan зберігаємо конфігурацію та ребутимо девайс


Читать далее

Обновлення firmware в комутаторах Edge-Core

Комментарии ()

Прошивку беремо тут - ftp://ftp.vimcom.ru/Accton_Edge-Core/Switches

#copy tftp file  
TFTP server IP address: 192.168.0.99
Choose file type: 1. config:  2. opcode: <1-2>: 2 
Source file name: es3510ma_v1.5.1.7.bix
Destination file name: es3510ma_v1.5.1.7.bix

ще пишуть що потрібно виконати

boot system opcode:<назва файла прошивки>

але в моєму випадку при оновленні ES3510MA цього не потрібно було робити


Читать далее

ProFTPD killed (signal 15)

Комментарии ()

Проблема полягає в тому, що ProFTPD не зупиняється під чес restart.

Для вирішення шукаємо в /etc/init,d/proftpd рядки

start-stop-daemon --stop --signal $SIGNAL --quiet --pidfile "$PIDFILE"

та редагуємо до виду

start-stop-daemon --stop --signal $SIGNAL --retry 1 --quiet --pidfile "$PIDFILE"

 


Читать далее

UNIDATA та радіозавади

Комментарии ()

При роботі з радіообладнанням від UNIDATA в момент, коли спостерігаємо радіозаваду, наприклад оттаку

неможливо зайти на веб-інтерфейс клієнтського девайсу, щоб змінити частоту. Це можна виконати, якщо втрати на каналі не є занад то великими, через telnet, наприклад:

configure radio frequency 5155000 bandwidth 10MHz
configure profiles save current
reboot

 


Читать далее

Запуск apache на FreeBSD 4.11

Комментарии ()

На старій версії FreeBSD 4.11 не стартує apache, напис скрипт який в кроні запускає

#!/usr/local/bin/ruby
cmd = `ps ax|grep http`
count = 0
cmd.each_line do |line|
unless (line.index("check_httpd") or line.index("grep"))
        count += 1
end
end
if count == 0
    `/usr/local/sbin/httpd`
    puts "Start httpd"
else
    puts "httpd is runinng...(#{count})"
end

 


Читать далее

Налаштування vlan в es3528m

Комментарии ()

#Режим конфігурації
configure

#Переходимо в режим управління vlan'ами
vlan database

#Створимо для прикладу vlan-id 100
vlan 100 "name" test media ethernet state active
#виходимо з режиму управління vlan'ами
exit

# налаштуємо 1-ий порт як теговий та включимо його в vlan-id 100 
interface ethernet 1/1
switchport mode trunk
switchport allowed vlan add 100 tagged
exit

# налаштуємо 2-ий порт як не теговий та включимо його в vlan-id 100 
interface ethernet 1/2
switchport mode access
switchport allowed vlan add 100 untagged
switchport native vlan 100
exit

# прописуємо ip-адресу та шлюз за змовчанням для vlan-id 100
interface vlan 100
ip address 192.168.1.100 255.255.255.0
ip default-gateway 192.168.1.1

# зберігаємо конфігурацію
copy running-config startup-config

# перегляд конфігурації
show running-config

 


Читать далее

Webit.in.ua 2013