Os6850e OSPF

Комментарии ()

Example

-> show configuration snapshot ospf
! OSPF :
ip load ospf
ip ospf area 0.0.0.0
ip ospf interface "vlan-934"
ip ospf interface "vlan-934" area 0.0.0.0
ip ospf interface "vlan-934" status enable
ip ospf status enable
-> show ip interface

 


Читать далее

MX80 Configuring a Filter to Block Telnet and SSH Access

Комментарии ()

Example

set firewall family inet filter local_acl term terminal_access from source-address 192.168.1.0/24
set firewall family inet filter local_acl term terminal_access from protocol tcp
set firewall family inet filter local_acl term terminal_access from port ssh
set firewall family inet filter local_acl term terminal_access from port telnet
set firewall family inet filter local_acl term terminal_access then accept
set firewall family inet filter local_acl term terminal_access_denied from protocol tcp
set firewall family inet filter local_acl term terminal_access_denied from port ssh
set firewall family inet filter local_acl term terminal_access_denied from port telnet
set firewall family inet filter local_acl term terminal_access_denied then log
set firewall family inet filter local_acl term terminal_access_denied then reject
set firewall family inet filter local_acl term default-term then accept
set interfaces lo0 unit 0 family inet filter input local_acl
set interfaces lo0 unit 0 family inet address 127.0.0.1/32

Source


Читать далее

Графік трафіку хостів у vlan'і на mx80

Комментарии ()

Задача: генерувати mrtg-графіки клієнтів, які включений у одному vlan'і

Наприклад в 777 vlan'і у нас є хост з mac 00:0c:db:fe:fd:30, конвертуємо в десятичну систему 0.12.219.254.253.48

Target[192.168.38.13_client1]: .1.3.6.1.4.1.2636.3.23.1.1.1.3.514.777.0.12.219.254.253.48
&.1.3.6.1.4.1.2636.3.23.1.1.1.5.514.777.0.12.219.254.253.48:public@192.168.38.13:::::2

 


Читать далее

Newsyslog.conf - ротація логів по масці

Комментарии ()

Для того щоб ротація здійснювалася по масці додайте прапор G в конфіг.

/var/log/nginx/*.log                 644  7     2000 *     JCG   /var/run/nginx.pid 30

 


Читать далее

Інсталяція модулів для Perl'а

Комментарии ()
perl -MCPAN -e 'install Net::SSH::Perl'
sudo apt-get install libmysqlclient-dev
perl -MCPAN -e 'install DBD::mysql'

 


Читать далее

Juniper MX80 - add read-only user

Комментарии ()
configure 
edit system login 
edit user michael  
set full-name "Michael Mike" 
set class read-only
set authentication plain-text-password
commit 

 


Читать далее

Proxmox: створення шаблону LXC контейнера

Комментарии ()

Після інсталяції LXC контейнера, та налаштування операційної системи (наприклад оновлення пакетів, встановлення необхідного ПО) можна зробити шаблон за декілька кроків

  • Видаляємо інтерфейс eth0 з /etc/network/interfaces
  • apt-get clean
  • rm /etc/hostname
  • rm /etc/resolv.conf
  • Вимикаємо контейнер
  • Запускаємо резервне копіювання для контейнера
  • Переносимл файл з папки резервних копій в папку шаблонів і перейменуйте його (/dump/xyz.tar.gz в папку /templates/cache/name-version.tar.gz)
  • Використовуйте новий шаблон для створення lxc-контейнерів
  • Після запуску налаштовуємо поштовий сервер sudo dpkg-reconfigure postfix

Джерело: тут

 


Читать далее

BDCOM P3310 option 82

Комментарии ()

example

interface EPON0/1
 description test
 epon pre-config-template ots binded-onu-llid 1-64
 epon bind-onu mac a0c6.ec07.6968 1
 filter dhcp
 switchport trunk vlan-allowed 115
 switchport trunk vlan-untagged none
 switchport mode trunk
 no switchport protected
!
!
ip dhcp-relay snooping
ip dhcp-relay snooping vlan  115
ip dhcp-relay snooping information option format hn-type
!

dhcp_pon.conf

max-lease-time 86400;

subnet XXX.XXX.162.128 netmask 255.255.255.128 {
    range XXX.XXX.162.135 188.190.162.200;
    #max-lease-time 120;
    max-lease-time 86400;
    option routers XXX.XXX.162.129;
    option domain-name-servers XXX.XXX.38.2,XXX.XXX.38.9;
    on expiry {
        set client-ip = binary-to-ascii (10, 8, ".", leased-address);
        execute("/usr/local/www/billing2a/public_html/dhcp/dhcp82_expiry.php", "option82", "expiry" ,"client-ip",client-ip);
    }

    on release {
        execute("/usr/local/www/billing2a/public_html/dhcp/dhcp82.php", "option82", "release");
    }
    on commit {

        set client-mac = binary-to-ascii(16,8,":",substring(hardware,1, 6));
        set switch-port = binary-to-ascii (10, 8, "", suffix( option agent.circuit-id, 1));
        set client-ip = binary-to-ascii (10, 8, ".", leased-address);
        set switch-addr = binary-to-ascii(10, 8, ".", packet(24, 4));
        set switch-mac=binary-to-ascii(16, 8, ":", suffix(option agent.remote-id, 5));

        execute("/usr/local/www/billing2a/public_html/dhcp/dhcp82.php", "option82", "commit",
        "switch-port",switch-port,
        "client-ip",client-ip,
        "client-mac",client-mac,
        "switch-addr",switch-addr,
        "switch-mac",switch-mac
        );

    }

}

Щоб отримувати mac OLT (Use cm-type option 82 format)

ip dhcp-relay snooping information option format cm-type

Щоб отримувати mac ONU (Use cisco option 82 format)

ip dhcp-relay snooping information option format hm-type

В конфігу dhcp

binary-to-ascii(16,8,":",substring(hardware,1, 6)); - mac клієнта

binary-to-ascii (10, 8, ".", leased-address); - ip клієнта

binary-to-ascii(16,8,":",substring(option agent.remote-id,0,6)); - mac адреса OLT або ONU

binary-to-ascii(10,8,"",substring(option agent.circuit-id,1,1)); - Vlan

binary-to-ascii(10,8,"",substring(option agent.circuit-id,3,1)); - номер epon порту із урахуванням к-ті ethernet портів. Якщо клієнт включений через 4-ий epon порт, то 6 портів ethernet + 4 = 10


Читать далее

BDCOM P3310 reset configuration

Комментарии ()
delete startup-config
reboot

 


Читать далее

OpenVPN with static key

Комментарии ()

Налаштування OpenVPN не зовсім легка справа для початківців, я б сказав трохи довго і нудно, але досить дешево для побудови закритого каналу. Для лінивих, старт vpn-ну за 5-ть хвилин на статичних ключах

Server - Ubuntu

apt-get install openvpn

Генеруємо статичний ключ

cd /etc/openvpn/
openvpn --genkey --secret static.key

Створюєсо конфігураційний файл серверу /etc/openvpn/server.conf

dev tun
port 7777
ifconfig 10.7.0.1 10.7.0.2 netmask 255.255.255.252

comp-lzo
daemon
keepalive 10 60
ping-timer-rem
persist-tun
persist-key
secret /etc/openvpn/static.key

Запускаємо сервер

/etc/init.d/openvpn start

Усе! У нас з'явився новий мережевий інтерфейс

# ifconfig 
tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:10.7.0.1  P-t-P:10.7.0.2  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

 


Читать далее

Webit.in.ua 2013