Полное отключение кеша в Firefox

Комментарии ()

В Firefox очень удобно работать, особенно благодаря большому количеству полезных расширений. Но камнем преткновения стал кеш. Вчера потратил пару часов на разбирательство, почему во всех остальных браузерах мой код JavaScript работает, а в Firefox нет. После отключения кеша все стало на свои места.

В адресной строке вводим

about:config

В конфиге находим следующие параметры и выставляем false

network.http.use-cache
browser.cache.offline.enable
browser.cache.disk.enable
browser.cache.disk_cache_ssl
browser.cache.memory.enable

После этих манипуляций, все заработало как нужно


Читать далее

FreeBSD Memory Disk

Комментарии ()

По сравнению с жестким диском, скорость записи оперативной памяти компьютера будет всегда самая быстрая. Диск в оперативной памяти - очень удобно к примеру для создания хранилища временных файлов - быстро работает, не дергаем жёсткий диск. И если Вам подходит, что после перезагрузки компьютера все файлы будут уничтожены.

Ядро FreeBSD должно быть скомпилировано с поддержкой Memory Disk

device  md

Создание  Memory Disk'а размером 512 МБ с точкой монтирования в /tmp. Прописываем в /etc/fstab

md    /tmp   mfs    rw,-s512m    2   0

Теперь при загрузке FreeBSD будет создан memory disk размером 512 Mb и смонтирован в /tmp
Для монтирования без перезагрузки, выполняем следующую команду

mount /tmp

Ручное создание и монтирование FreeBSD Memory Disk

Делается одной командой

mdmfs -o async,noatime,nosuid -s 250m md /tmp/tmp

создается виртуальный диск размером 250 мегабайи и монтируется в /tmp/tmp. Часто использую при разворачивании бэкапа, когда загружен с LiveCD. Кроме этого, указываем системе, где наш TMPDIR находится

setenv TMPDIR /tmp/tmp

 


Читать далее

Создание диска в файле и монтирование в FreeBSD

Комментарии ()

Понадобилось временно расширить диск tmp гиг так на 120. 

Создадим виртуальный Memory Disk размером 120 Гигабайт (в Килобайтах это будет 125829120):

# dd if=/dev/zero of=image_tmp bs=1024 count=125829120
# mdconfig -a -t vnode -f image_tmp -u1

Теперь у нас появится виртуальное блочное устройство /dev/md1. Отформатируем его в файловую систему UFS и примонтируем в /tmp:

# newfs /dev/md1
# mount /dev/md1 /tmp

Просмотр списка виртуальных дисков 

# mdconfig -l
md1

Удаление устройства из системы  (раздел  должен быть отмонтирован):

# umount /home/virtual
# mdconfig -du1

Для монтирования виртуального диска при старте системы, пропишем следующие в /etc/rc.local:

mdconfig -a -t vnode -f /home/image0 -u 1
mount /dev/md1 /tmp

 


Читать далее

Alcatel OmniStack LS 6224 - базовая настройка

Комментарии ()

Vlan'ы

Создание vlan'а (пример создания дву vlan'ов)

console> enable
console# configure
console(config)# vlan database
console(config-vlan)# vlan 200
console(config-vlan)# vlan 945

Назначаем vlan'ы тегированому порту

console(config)# interface ethernet g1
console(config-if)# switchport mode trunk
console(config-if)# switchport trunk allowed vlan add 200
console(config-if)# switchport trunk allowed vlan add 945

Назначаем vlan access(не тегированому) порту 

console(config)# interface ethernet e24
console(config-if)# switchport mode access
console(config-if)# switchport access vlan 200

Перевод диапазона портов в режим trunk

interface range ethernet e24,g1
switchport mode trunk

Прописываем названия Vlan'ов  и назначаем ip-адрес

console(config)# interface vlan 200
console(config-if)# name access
console(config-if)# ip address 10.15.200.13 255.255.255.0

Настройка авторизации

console(config)# aaa authentication enable default line
console(config)# aaa authentication login default line

console(config)# line ssh
console(config-line)# password <my password>

console(config)# line console
console(config-line)# password <my password>

Генерируем ключ (dsa/rsa) нужен для запуска ssh-сервера

console(config)# crypto key generate dsa

Включаем ssh-сервер

console(config)# ip ssh server

Сохраняем конфигурацию

console# copy running-config startup-config

 


Читать далее

FireFox и крякозябра

Комментарии ()

Проявилось пока только в FireFox'е. Если выполнять POST запрос и выводить на страницу данные (исходники проекта в UTF-8) то будут крякозябры. Помогло только это:



header('Content-Type: text/html; charset=UTF-8');

Размещать нудно в самом начале php-файла


Читать далее

Эффект размытия с помощью CSS3 и jQuery

Комментарии ()

Сегодня вы увидите, как создать простой эффект размытия для текстовых элементов. Основная задача – есть набор текстовых блоков, которые будут размываться и уменьшаться, когда мы проводим над ними указателем мыши. Элемент в фокусе будет увеличиваться. Это создаст эффект фокуса, который привлечет внимание к элементу, над которым указатель мыши находится сейчас.


Читать далее

Валидация формы - практика

Комментарии ()

Подробнее о теории построения валидации читайте тут

Задаем правила

Все правила проверки объяденяются в группы правил (rule_group), которые описываются в виде массива.  Правила задаются через метод addRule($array_rules) и храняться в папке /config/rule, каждаю группа правил в отдельном файле. Для группы правил с названием auth файл /config/rule/rule_auth.php

Пример задания правил (группа правил с именем auth)

$params=array();
$rules=array();

$rule=array();
$rule['rule_name']='required';
$rule['element_id']='login';
$rules[]=$rule;

$rule=array();
$rule['rule_name']='required';
$rule['element_id']='password';
$rules[]=$rule;

$params['auth']['rules']=$rules;

$this->addRule($params);

Как использовать?

Задаем id формы

<form ... id="form_auth">

Все елементы ввода формы, которые участвуют в валидации, должны содержать атрибут data-validator, который должен содержать идентификатор веб-формы

<input  name="login" id="login" type="text" value=""   data-validator="form_auth"  >

Добавляем вызов javascript-функции валидации

<script>
$(document).ready(function(){
$('#btn_login').click(function(){
	if (checkRule('auth','form_auth'))
	{
		$('#form_auth').submit();
	
	} 
      })
})
</script>

Первый параметр - название группы валидации, 

Второй параметр - идентификатор веб-формы


Читать далее

Валидация формы

Комментарии ()

Валидация формы одна из саммой рутинной работы. Куда не посмотриш, везде форма взаимодействия человека с сайтом. С одной стороны валидация - мера предосторожности, с другой  это некий хелп для человека, при взаимодействии с веб-страницой


Читать далее

Драйвера для C-Media CMI8738/C3DX Audio Device

Комментарии ()

Маленькие, рабочие и, естественно, бесплатные. Поддерживается Windows XP, Vista, Seven и 2008 server, x86 и x64

Скачать

 


Читать далее

Установка Windows XP на USB Flash Drive

Комментарии ()

http://flashboot.ru/bootable_flash/2012/11/05/install-windows-xp-usb.html


Читать далее

Webit.in.ua 2013