Резервні копії iTunes на диску D

Комментарии ()

В налаштування iTunes немає можливості задати шлях до папки із резервними копіями. На форумі найшов ідею створення ссилки

Переносимо дані з c:\Users\<user name>\AppData\Roaming\Apple Computer\MobileSync/Backup на  D:\Backup та в cmd із під адміністратора виконуємо

mklink /D Backup D:\backups

 


Читать далее

Реєстрація та встановлення SSL сертифікату

Комментарии ()

Генерация CSR для домена

Для отримання SSL-сертифікату домену, необхідно створити CSR запиту.

CSR - спеціальний цифровий ключ, який містить зашифровану інформацію про власника сертифіката, компанії і домені.

Для генерації секретного ключа (key) і запиту на сертифікат (CSR) використовується утиліта OpenSSL. Ця утиліта, як правило, входить в стандартну поставку веб-сервера Apache.

openssl req -newkey rsa:2048 -nodes -keyout www.mydomain.com.key -out www.mydomain.com.csr

Common Name - повне доменне ім'я для веб-сервера в форматі FQDN - Fully Qualifed Domain Name. Увага! Всі сертифікати, крім Wildcard Certificate, захищають тільки один хост - наприклад, або сам домен виду "mydomain.ru", або "www.mydomain.ru", або будь-який субдомен виду "secure.mydomain.ru". Будьте уважні, Вам необхідно вказати саме те ім'я домену, на яке виписується сертифікат.

openssl req -noout -text -in www.mydomain.com.csr - перевірка правильності сертифікату

В результаті цих дій буде створено і збережено в файлі www.mydomain.com.csr запит на сертифікат (CSR). Також буде згенеровано і збережений в файл www.mydomain.com.key секретний ключ 2048 RSA.

Отримання SSL-сертифікату

окрім платного варуанту, є ресурси на яких можна отримати безкоштовно SSL-сертифікат на 3 місяця

https://www.sslforfree.com/

Установка SSL-сертифіката на сервер

Для Apache'а

1. Скопіюйте файл www.mydomain.com.key з сертифікатом в директорію, в якій Ви плануєте зберігати Ваші ключі (за замовчуванням: /usr/local/apache/conf/ssl.key/ or / etc / httpd / conf / ssl. key /).

2. Скопіюйте сертифікат в файл www.mydomain.com.crt і помістіть файл в директорію, в якій Ви плануєте зберігати Ваші сертифікати (за замовчуванням: /usr/local/apache/conf/ssl.crt/ or / etc / httpd / conf /ssl.crt/).

3. Відкрийте конфігураційний файл Apache httpd.conf (або файл ssl.conf) в текстовому редакторі.

4. Знайдіть секцію VirtualHost, що описує домен, для якого встановлюється сертифікат. Перевірте наявність двох директив і додайте їх в разі їх відсутності, вказавши правильні шляхи до файлів сертифіката і ключа:

SSLCertificateFile /usr/local/apache/conf/ssl.crt/www.mydomain.com.crt

SSLCertificateKeyFile /usr/local/apache/conf/ssl.key/www.mydomain.com.key


5. Збережіть зміни.

6. Перезавантажте веб-сервер однієї з команд:

/ Usr / local / apache / bin / apachectl startssl

або

/ Usr / local / apache / bin / apachectl restart

NGINX

в конфіг хоста добавляємо три рядка

listen 443 ssl;
ssl_certificate /opt/nginx/ssl/certificate.crt;
ssl_certificate_key /opt/nginx/ssl/private.key;

Приклад, коли нам потрібно прийняти ssl та прокинути на інший веб сервер

server {
    listen      XXX.XXX.XXX.XXX:443;
    ssl on;
    ssl_certificate /home/vps/conf/web/ssl/mary/certificate.chained.crt;
    ssl_certificate_key /home/vps/conf/web/ssl/mary/private.key;

    server_name mydomainl.org www.mydomain.org;
    location / {
	proxy_pass  http://192.168.1.103:80;
    }

}

sslshopper.com - сервіс перевірки коректності ssl-сертифікату сайту

При виникнені помилки

The certificate is not trusted in all web browsers. You may need to install an Intermediate/chain certificate to link it to a trusted root certificate.

читаємо про ланцюжки SSL-сертифікатів тут та усуваємо це


Читать далее

Розбираємо q-in-q vlan та віддаємо у клієнтський порт

Комментарии ()

Приклад

Комутатор: des-1210-26/ME

vlan: 3964

uplink port: 25

client port: 17

-------------------------------------

vlan 3964: 25(t), 17(u)

QinQ Settings

17 port - UNI 0x8100

25 port - NNI 0x8100

 


Читать далее

Install Icinga2 on Ubuntu 16.04

Комментарии ()

insert next string in /etc/apt/sources.list.d/icinga.list

deb https://packages.icinga.com/ubuntu icinga-xenial main
sudp apt install curl
curl -sSL https://packages.icinga.com/icinga.key | sudo apt-key add -
sudo apt-get update

Install LACP

sudo apt-get install apache2 mysql-server
sudo mysql_secure_installation
sudo apt-get install php libapache2-mod-php php-mcrypt php-mysql
sudo nano /etc/apache2/mods-enabled/dir.conf
<IfModule mod_dir.c>
        DirectoryIndex index.php index.cgi index.pl index.html index.xhtml index.htm
</IfModule>
sudo systemctl restart apache2

Перегляд доступгим модулів php у вигляді пакетів

apt-cache search php- | less
sudo apt-get install icinga2 icinga2-ido-mysql
sudo icinga2 feature enable ido-mysql command
sudo systemctl restart icinga2

Installing the Icinga Web Interface

sudo nano /etc/php/7.0/apache2/php.ini
date.timezone = Europe/Kiev
sudo systemctl restart apache2

Setting up the Icinga Web Interface

sudo icingacli setup token create

https://www.digitalocean.com/community/tutorials/how-to-install-icinga-and-icinga-web-on-ubuntu-16-04

 icinga2 feature list
apt install nagios-plugins
icinga2 feature enable api

 


Читать далее

Bpdufilter

Комментарии ()

Extremexos

edit policy bpdu_filter
entry BPDUfilter1 {
    if {
        ethernet-destination-address 01:00:0c:cc:cc:cd;
    } then {
        deny;
    }
}
entry BPDUfilter2 {
    if {
        ethernet-destination-address 01:80:C2:00:00:00;
    } then {
        deny;
    }
}
conf access-list bpdu_filter ports 1 ingress

Alcatel Lucent os6850e

policy port group UserPorts 1/2
qos user-port filter bpdu
qos apply

 


Читать далее

Базове налаштування комутатора Eltex

Комментарии ()
console#configure
console(config)#vlan 200
console(config)#ex
console(config)#interface vlan 200
console(config-if)#ip address 10.15.200.201 255.255.255.0
console(config-if)#ex
console(config)#interface GigabitEthernet 0/24
console(config-if)#switchport mode trunk
console(config-if)#switchport trunk allowed vlan add 200
console(config-if)#ex
console(config)#interface GigabitEthernet 0/23
console(config-if)#switchport mode access
console(config-if)#switchport access vlan 200
console(config-if)#ex
console(config)#ip default-gateway 10.15.200.254

wr - збереження конфігурації


Читать далее

Заборона зміни/знищення папки

Комментарии ()

За допомогою chattr виставляємо атрибут immutable, який забороняє змінити/знищити файл/папку  навіть root'і, поки цей атрибут не буде знятий

Виставити атрибут

chattr +i /path_to_file_or_folder

Зняти атрибут

chattr -i /path_to_file_or_folder

 


Читать далее

Quanta LB6M

Комментарии ()

24 порта SFP+ 10G (гігабіт не вміє)

4 мідних порта 100/1000Mb

два блока живлення

Створюємо користувача mylogin з правами адміністратора

(FASTPATH Routing) (Config)#username mylogin password <my password> level 15

Назначуємо ip адресу на порт управління MGNT

(FASTPATH Routing) #serviceport protocol none
(FASTPATH Routing) #serviceport ip 192.168.0.240 255.255.255.0 192.168.0.2

Прописуємо vlan 200 на 25,26 порти tag та 27 порт untag

(FASTPATH Routing) #vlan database
(FASTPATH Routing) (Vlan)#vlan 200
(FASTPATH Routing) (Vlan)#ex
(FASTPATH Routing) #configure
(FASTPATH Routing) (Config)#interface 0/25-0/26
(FASTPATH Routing) (Interface 0/25-0/26)#vlan participation include 200
(FASTPATH Routing) (Interface 0/25-0/26)#vlan tagging 200
(FASTPATH Routing) (Interface 0/25-0/26)#ex
(FASTPATH Routing) (Config)#interface 0/27
(FASTPATH Routing) (Interface 0/27)#vlan participation include 200
(FASTPATH Routing) (Interface 0/27)#vlan pvid 200

Зберігаємо конфігурацію

write memory

 


Читать далее

Java.net.socketpermission connect resolve

Комментарии ()

шукаємо %JRE_HOME%/lib/security/java.policy та добавляємо

grant {
 permission java.net.SocketPermission "192.168.1.10:443", "connect,resolve";
};

 


Читать далее

Birdc

Комментарии ()
  • birdc show protocols all - показати усі протоколи
  •  show route protocol <protocol_name> - показує прийняті маршрути від <protocol_name>
  •  show route export <protocol_name> - показує анонсовані маршрути для <protocol_name>
  • show route where (28681,21) ~ bgp_community - показати маршрути із ком'юніті 28681:21
  • bird> configure - перечитати конфіг
  • reload in <protocol> | "<pattern>" | all       Reload protocol (just imported routes)
    reload out <protocol> | "<pattern>" | all      Reload protocol (just exported routes)
    наприклад
    reload out gtu - перечитати префікси які віддаємо для описаного раніше протокола GTU


Читать далее

Webit.in.ua 2013